Back to Flashcart Help
TTDSi Firmware v.1.4 fix help!
L
Hello,
I have read on several different websites that, in order to upgrade your flashcard to 1.4 so it can work on the DSi (which has been upgraded to 1.4), I need to download three files, load the .nds upgrade on my card, then follow the instructions.I have tried several times using different versions of the menu (1.17, 1.18, and 1.15) to no avail.
Either I get a white screen and nothing happens, or it loads and tells me that the card version is not supported.I ran a check and my card is real.Any help? I just want to be able to use my card on my new DSi.
F
The versions you have tried are kernels, you need the upgrade patch http://www.ndstt.biz/dstt-download/dstti-3ds-V2.1.0-dsi-v1.43-firmware-download.htmlThe upgrade patch is for the DSi up to version 1.43, you will need a DS console (Ds/Lite DSi or 3DS) that your cart works on to upgrade your cart.
L
I installed the upgrade patch, but still my DSi didn't want to read it. Guess it must be because of that version problem. Strange, I could swear I read that some people had managed to make it work on version 1.44...Is there absolutely no way to downgrade the version of the DSi? When I bought it, it worked fine, but then someone updated it and even with the factory reset, the version remains the same.
L
no, the DSi cannot be downgraded.
F
LordArkana · #3I installed the upgrade patch, but still my DSi didn't want to read it. Guess it must be because of that version problem. Strange, I could swear I read that some people had managed to make it work on version 1.44...Is there absolutely no way to downgrade the version of the DSi? When I bought it, it worked fine, but then someone updated it and even with the factory reset, the version remains the same.
The link i supplied for the patch, as i said in my previous post is for the DSi up to version 1.43.
So if your DSi is on 1.4.4 then you need to purchase another flashcart.
Showing posts 1–5 of 5 · This discussion is archivedBack to top